Blog

Blog

PHODAL

Homebrew versions安装特定版本软件

在之前有一篇文章是brew versions gradle安装指定版本gradle,结果在重新试了下之后失败了。

brew versions

出现了下面的错误

brew versions gradle
Error: Unknown command: versions

原因是在更新Mac OS的时候一些东西已经没了

brew versions install

所以需要tap这个

brew tap homebrew/boneyard

接着就可以使用brew versions

Warning: brew-versions is unsupported and will be removed soon.
You should use the homebrew-versions tap instead:
  https://github.com/Homebrew/homebrew-versions

2.1      git checkout 5475eb4 /usr/local/Library/Formula/gradle.rb
2.0      git checkout 94fcdae /usr/local/Library/Formula/gradle.rb
1.12     git checkout 8ef0672 /usr/local/Library/Formula/gradle.rb
1.11     git checkout 01f2e6f /usr/local/Library/Formula/gradle.rb
1.10     git checkout c6baa40 /usr/local/Library/Formula/gradle.rb
1.9      git checkout 5bab5e9 /usr/local/Library/Formula/gradle.rb
1.8      git checkout 9214e60 /usr/local/Library/Formula/gradle.rb
1.7      git checkout f826cc9 /usr/local/Library/Formula/gradle.rb
1.6      git checkout fff7c0b /usr/local/Library/Formula/gradle.rb
1.5      git checkout 57931e0 /usr/local/Library/Formula/gradle.rb

关于我

Github: @phodal     微博:@phodal     知乎:@phodal    

微信公众号(Phodal)

围观我的Github Idea墙, 也许,你会遇到心仪的项目

QQ技术交流群: 321689806
comment

Feeds

RSS / Atom

最近文章

关于作者

Phodal Huang

Developer, Consultant, Writer, Designer

ThoughtWorks 高级咨询师

工程师 / 咨询师 / 作家 / 设计学徒

开源深度爱好者

出版有《前端架构:从入门到微前端》、《自己动手设计物联网》、《全栈应用开发:精益实践》

联系我: h@phodal.com

微信公众号: 与我沟通

标签