Blog

Blog

PHODAL

Mac OS 10.9安装gevent

事情本来很简单,但是过程中在不断有错误出现。。主要是clang..

开始之前

安装好Xcode以及brew

安装 brew

 ruby -e "$(curl -fsSL https://raw.github.com/Homebrew/homebrew/go/install)"

安装gevent

需要先安装libevent

 brew install libevent

还需要安装cython

 pip install cython

接着就是greenlet

sudo pip install greenlet

如果可以很幸运的安装gevent

sudo pip install gevent

如果没有的话

安装报错

安装cython报错

 export ARCHFLAGS="-Wno-error=unused-command-line-argument-hard-error-in-future"

安装greenlet报错

 clang: error: unknown argument: '-mno-fused-madd' [-Wunused-command-line-argument-hard-error-in-future]
 clang: note: this will be a hard error (cannot be downgraded to a warning) in the future
error: command 'cc' failed with exit status 1

那么

 sudo ARCHFLAGS="-Wno-error=unused-command-line-argument-hard-error-in-future" pip install greenlet

或许您还需要下面的文章:

关于我

Github: @phodal     微博:@phodal     知乎:@phodal    

微信公众号(Phodal)

围观我的Github Idea墙, 也许,你会遇到心仪的项目

QQ技术交流群: 321689806
comment

Feeds

RSS / Atom

最近文章

关于作者

Phodal Huang

Developer, Consultant, Writer, Designer

ThoughtWorks 高级咨询师

工程师 / 咨询师 / 作家 / 设计学徒

开源深度爱好者

出版有《前端架构:从入门到微前端》、《自己动手设计物联网》、《全栈应用开发:精益实践》

联系我: h@phodal.com

微信公众号: 与我沟通

标签